
 

 

Making DVDs using MPEG Streamclip and DVD Styler 
 
Version 1.4    Author: Chris Playll 
 
This guide provides step by step instructions for making a DVD copy of a Topfield recording using a 
Windows PC.  
There are several methods of doing this, so this guide begins by describing some of the basic principles 
and then some of the options available. This is then followed by the detailed step by step guide for one 
method. 
 
A. INTRODUCTION 
 
Why Use a Computer? 
The first question that you may ask is why not just copy the programme directly  from the Topfield to a DVD 
recorder. 
You may feel that this is a simpler solution and may be more convenient if your DVD recorder is 
permanently connected to your Topfield PVR. This method gives predictable results, if you are not bothered 
about removing commercial breaks from your DVD copy, and don't mind any unwanted extra material after 
the programme. 
 
There are some disadvantages. 
The programme has to be copied at normal speed, during which time the Topfield cannot be used for 
anything else.  
You need to manually start and stop the DVD recorder at the correct time which means being available 
when the programme finishes, possibly by setting an alarm on your watch or phone to remind you. If you 
are recording several programmes on one disc this means starting and stopping the recording after each 
programme. 
 
There will be some loss of quality since you will be decoding the Topfield files to analogue vision and sound 
and then re-encoding them in the DVD recorder.  
 
Although it is possible to edit a programme in the Topfield before copying it, this editing function is not very 
accurate and involves cutting the original file which cannot be undone. 
 
If you use a computer to make a DVD, you can edit a copy of the files more accurately and, once you have 
set up the details of the process required, you can leave the computer to get on with it. 
 
A DVD recorder may be useful if you have problems with a faulty Topfield recording. If you can copy the 
programme on to a DVD recorder, you can then import the DVD into MPEG Streamclip and then follow the 
method described in the guide.  
 
MPEG File Types 
DVDs and Topfield recordings both use MPEG files. DVDs use MPEG Program Stream files, whereas 
Digital TV broadcasts use MPEG Transport Stream files, which are designed to be more robust over error 
prone transmission paths. Digital TV broadcasts use a range of quality settings.  In the UK, BBC1 has the 
highest quality, while the shopping channels have the lowest quality. 
 
The MPEG transport stream broadcast contains, not only the vision and stereo sound, but also additional 
sound tracks, such as audio description for the partially sighted, subtitles and other programme information. 
 
 



 

 

The Topfield PVR records the complete transport stream, adding its own extra information to make a .rec 
file. 
 
Files with an extension on their name of .mpg or .m2p are "multiplexed" MPEG files which contain both 
vision and sound streams. These files can be "demultiplexed", a process which separates the individual 
vision and sound tracks into separate files. 
Files with an extension .mpv or .m2v are vision files.  
Files with an extension .mpa or .mp2 are sound files. 
 
The programs described in this guide can handle both multiplexed MPEG files and separate vision and 
sound MPEG files. The advantage of a multiplexed file is that you can play it to check that the vision and 
sound are not out of sync, which can be a problem with converted Topfield files. Separate vision and sound 
files may reduce processing time when creating a DVD, but vision and sound synchronising errors will not 
be apparent until the DVD is played.  
 
How do MPEG files compress the picture? 
The MPEG system uses a number of methods to reduce the data rate. 
An uncompressed standard definition TV picture consists of 740 pixels horizontally and 576 pixels vertically.  
A complete set of pixels (a frame) is produced 25 times a second.  
 
The MPEG system also makes use of the fact that, in a typical TV signal, one frame is usually very similar 
to the next. The system divides the vision signal into Groups of Pictures (GOPs) each consisting of typically 
12 frames. The first frame, known as an I frame or a key frame, transmits the full 740x576 pixel detail. For 
the remaining frames in the GOP, known as P frames, only the differences between that frame and the 
previous frame are transmitted. Unless there is a picture cut, or a lot of fast movement, the data in a P 
frame will be considerable lower. 
 
Some TV stations, broadcasting at a lower quality, may choose to reduce the data rate further by using 
longer GOPs of up to 50 frames. Since TV broadcasts are designed to be viewed continuously at normal 
speed, the only problem with a long GOP is the delay when changing channels before a picture appears. 
 
The data rate can also be lowered by reducing the horizontal detail. Some transmissions have only 544 
horizontal pixels, giving a picture size of 544x576. 
 
Some transmissions use a picture size of 704x576. This has no practical effect on the quality as the missing 
8 pixels on each side of the picture are off the edge of most TV screens.  
 
For more details on individual tv channels in the UK, there is a table available on the internet at dtt.me.uk. 
 
The official DVD-Video Specification does not accept 544x576 pictures or a GOP of more than 15 frames. 
However, most recent DVD players seem to play these pictures OK. When making a DVD, you have a 
choice of either re-encoding the vision to meet the official specification, which can take a long time on a 
computer, or save time by copying the existing file, and hope the DVD plays OK. 
 
One useful test that you can try is to make a Topfield recording of one of the shopping channels, which use 
the lowest quality. Make a DVD copy of this recording without re-encoding the file. You can then check that 
this DVD will play OK on any DVD player that you may wish to use. 
 
It is possible to view MPEG files on a computer and to copy these files on to a DVD. However, in this case, 
a DVD data disc will be created which can only be viewed on a computer. In order that the DVD can be 
played on a standard DVD player a DVD-Video format disc must be created using a process like the one 
described below.   



 

 

Editing MPEG Files 
You will probably want to edit the files to remove any extra material before and after the programme. If the 
programme has commercial breaks, you will probably want to remove these also. 
 
It is only possible to edit an MPEG file at the start for a key frame, in order to preserve the GOP sequence. 
If you want to be able to edit any frame to any other frame, it is necessary to decode and recode the MPEG 
file. 
 
To do this you will need to buy a some editing software, as the free software available will not do this. If you 
received some DVD making software with your computer when you bought it, or have obtained on some 
software on a magazine cover disc, you will probably find that the editing function is disabled unless you 
pay for the full product. However, if you just want to remove commercial breaks, editing the MPEG file to 
the nearest key frame using the free software described in this guide will probably be good enough for 
home viewing purposes. You will probably just get a small hole or jump on the sound.     
 
DVD Audio Problems 
A occasional problem with DVDs is that the audio can go out of sync with the vision or be missing for part of 
a title. MPEG files contain information to keep the vision and sound in sync, so that it is possible to start 
playing the file at any point in its length. When the files for a DVD are created, the vision and sound 
information is split into separate files and then put back together again in another combined file. If there are 
any errors, such as missing frames, in either the vision and sound files they will not fit back together 
correctly. Any errors will accumulate throughout the programme so that, if the sound goes out of sync, it will 
remain so. For this reason it is important to check any DVD produced to ensure that the audio is present, 
and in sync with the vision, at the end of each title.    
 

B. OPTIONS 
 
There are a number of stages involved in making a DVD and a range of software that can be used. 
Listed below are the various stages and some of the options. The guide that follows is in sections so you 
can mix and match the options according to your preferences and what software you may already have. 
 
Making a DVD from a Topfield recording involves the following stages. 
 
1. Copy the Topfield .rec file to your computer. 
 
The Topfield has a USB connection which can be connected to a computer via a standard USB cable. 
Unfortunately it is not possible to access the files directly via normal Windows programs, as you would with 
an external hard disc. The file needs to be first transferred to your computer. 
 
A program to do this is, “Altair“, has been written by Topfield and can be downloaded from their website as 
part of the Topfield Tools package (www.topfield.co.uk). However, this program will only work with Windows 
XP or Vista (32-bit version). It will not work with 64-bit Windows systems, including Windows 7, which is 
always pre-installed on new computers in its 64-bit version. There is no indication that Topfield are going to 
develop a 64-bit version of Altair. 
 
As a result a Topfield user, Henry Heselgrove (“qubits”), has developed an alternative file transfer program 
called “Antares” Since this program works with both 32 and 64 bit systems, and has several additional 
features, it will be the one described in detail later in this guide. 
 
An alternative option for 64-bit systems is to use Altair together with the driver used by Antares and a 
specially written .dll file. This approach will be necessary to use the other Topfield Tools programs. See the 
Antares website for more details. 



 

 

2. Convert the Topfield .rec file to an MPEG file. 
 
Topfield's own .rec files are not readable by most MPEG software. It is necessary to convert them to 
standard MPEG program stream files containing the vision and sound tracks required. If the DVD authoring 
program that you are using in the next stage does not have an editing function, you will need to do any 
editing required to the MPEG file in this stage. 
 
MPEG Streamclip    (www.squared5.com) 
This program will play, edit and convert a wide range of files. This is the program described in detail later in 
this guide. 
 
Project X     (www.oozoon.de) 
This is an alternative file conversion program, although with a less user-friendly layout.  Editing can be 
achieved by marking a series of cut points which are actioned when the file is converted. This program does 
not play the vision and sound so, if you wish to view your edited file, it is necessary to convert the file first 
and then view the result in another program.  
 
PVAStrumento   (www.offeryn.de) 
This file conversion program does not accept Topfield .rec files, but will convert MPEG Transport stream 
(.ts) files. Users report that it is a good program for fixing audio problems with MPEG files. As a result 
several users recommend using either MPEG Streamclip followed by PVAStrumento  or Project X followed 
by PVAStrumento.  
 
Video Redo  (www.videoredo.com) 
This is generally considered to be the best, and easiest to use, program, for this purpose. It is, however, a 
commercial product and  has to be purchased online ($49.99) after a 1 month free trial. It enables frame 
accurate editing without the need to re-encode the entire file when converting to an MPEG file. If you buy 
the Video Redo TV Suite version ($74.99), this includes the DVD authoring and burning software. 
 
Rec2mpg and Rec2dvd Conversion Scripts   (www.landk.ukfsn.org) 
These scripts, written by a Topfield user, SonicLife, can be set up to control the Project X program. They 
enable you to convert a file in a single operation, avoiding the need to learn how to use the Project X 
program itself. 
   
“rec2mpg” will convert a .rec file to an .mpg file  (no editing option) 
 
“rec2 dvd” will convert a .rec file to a set of DVD files in a VIDEO_TS folder. A DVD burning program that 
can burn these files as a DVD-Video format disc will then be required. The programme can be edited by 
adding bookmarks to the file in the Topfield recorder before copying the file to your PC. This script also 
offers the easiest way to copy the transmitted subtitles for the deaf to an optional subtitle file for the DVD.  
The basic DVD created with this script will have no menu with the titles played in alphabetical order. 
 
3. DVD Authoring 
 
This is the name for the process of converting the MPEG files to the .vob files which are the files recorded 
on a DVD. Authoring also includes creating a menu for the DVD. 
 
There is a wide choice of commercial software that you can buy for this. Most are multimedia packages 
designed for music and photos as well as video, so your purchasing decision may depend on what else you 
may want to use your computer for. Nero (www.nero.com) is probably the most popular commercial 
package with Topfield users 
 



 

 

Most commercial DVD software is designed mainly for editing and creating menus for home video. It will 
enable you to edit the pictures more accurately than editing the MPEG file. 
   
There are, however, several free DVD authoring programs which are adequate for many purposes, 
although they do not have editing functions.  
 
DVD Styler 
(www.dvdstyler.org) 
This program gives the option to either copy or re-encode the vision and audio files. Copying the files 
maintains the original quality and considerably reduces the time taken to create the DVD. Chapter points 
can be selected and it is possible to design a wide variety of menus. There is a choice of creating the DVD 
files, creating a disc image or burning a disc. This is the program described in the guide below.  
 
The following 3 free programs are all probably easier to use, but are slower and have fewer features. 
 
Windows DVD Maker 
This program is supplied with as part of Microsoft Windows 7 and some versions of Vista. All files are re-
encoded to a fixed quality giving a maximum duration of 150 minutes on a DVD. There is a range of 
sophisticated animated menus available. Menu backgrounds and text can be changed. There is no control 
over chapter points or thumbnail selection for the menu buttons. There is no option of creating a disc 
image. Creating a DVD can take up to 2 hours, since the process is designed to take place in the 
background so you can continue to use your computer for other tasks.  
 
Not to be confused with the program of the same name at www.windows-dvd-maker.com. This is a product 
from a website in Singapore that requires payment for full functionality.  
 
DVD Flick 
(www.dvdflick.net) 
This program offers an option not to re-encode the vision, but the program will always re-encode vision that 
does not have a pixel size of 740x576. Audio is always re-encoded to AC3. There is a limited range of 
menus.  
 
Freemake Video Converter  
(www.freemake.com) 
A useful file conversion program which includes a DVD authoring option. All source files are re-encoded 
with the encoding quality automatically set to match the duration of the material. These are 3 basic menus, 
with no preview option. A title for the disc can added. The text for individual titles is only displayed on the 
“text “ menu option and is taken from the source file names. There is file editing option, but it is difficult to 
use accurately as the only navigation controls are a slider control and single frame advance/retard buttons. 
 
4. Burn the DVD files on to a DVD disc. 
 
Most DVD authoring programs include software to burn the files it has created on to a DVD.  
DVD-R discs can only be burnt once. If your intention is to make a permanent copy, these are the best ones 
to use. 
DVD-RW discs can be erased and reused, but are more expensive and take longer to burn. 
DVD+R and DVD+RW discs are the alternative DVD format and, although most DVD drives can use them, 
offer no advantage.   
In order to avoid wasting discs while experimenting, one option is to burn a DVD-RW disc and test it on your 
DVD player.  If you are happy with the result, you can then copy it on your computer to DVD-R disc to make 
a permanent copy. The DVD-RW disc can then be reused. 



 

 

Alternatively, it is possible to get your DVD authoring program to create a disc image, an .iso file, which is 
an exact copy of what would be burnt on to a disc. You can then check this file, and if OK, burn a 
permanent copy to a DVD-R disc. 
 
File Playing Programs  
It is useful to be able check any of the files created. Windows Media Player, already installed on your 
computer, will play mpeg files and will give a smoother replay than MPEG Streamclip.  
 
VLC Media Player 
(www.videolan.org) 
It is worth installing this program in order to replay a wider range of files, including .rec, .ts  and .iso files. It 
is useful if you need to check the .rec files transferred from your Topfield. It can also be used to check an 
.iso DVD image file, created by a DVD authoring program, before burning to disc. 
 

C. GUIDE 
 
This guide provides step by step instructions for one method, using MPEG Streamclip and DVD Styler. It is 
written in sections so that, if you prefer a different method, you can just use those sections that you require. 
 
Before starting it is a good idea to create a new folder in your computer for the files produced, with sub-
folders for each of the stages. A separate folder for the program files for Antares, MPEG Streamclip, and 
PVAStrumento  is also useful. 
 
1. Copy the Topfield .rec file to your computer. 
 
Download Antares. 
Go to http://users.on.net/~henry/antares/index.html and download “zipped antares executable” 
When downloaded, right-click on the file and unzip it to a suitable folder. 
 
Antares does not come with an installation program. The Antares.exe file runs the program directly.  
It is useful to create a shortcut for the program on your computer's desktop area. Right click the 
Antares.exe file and select Create Shortcut. A shortcut will appear in the folder. Select it and, holding down 
the left button on your mouse, drag it on to the desktop area of your computer.   
 
The easiest way install the USB driver required (topfield-libusb-winusb) is to download the file 4zt.exe from 
the Antares website. Download the a zip file, and unzip it to the same location as the Antares file. 
. 
If you need physically move the Topfield in order to reach your computer, only mains power and the USB 
lead need to be connected. 
 
With the USB lead connected, press standby on the Topfield to switch it on. Run 4zt.exe to install the USB 
driver. 
 
Run Antares.exe. 
 
 
 
 
 
 
 
 



 

 

The Topfield files should appear in the left 
window.  
Your computer's files will appear in the right 
window. 
If the left window is blank, there is a problem 
with the connection. 
 
Unless you are using the Topfield to make 
recording at the same time, leave Turbo ticked, 
which will speed up the transfer. 
 
On the left window select the Data files folder 
which contains the programme (.rec) files. 
 
On the right window select the folder where you 
wish to put the copied files. 
 
 
Copy the required file from the left window to the right window, by clicking the right pointing arrow. 
To copy several files at the same time, hold the control key while selecting the file names.  
 
A progress bar will appear while the file is copied. 

 
A 1Gb file takes about 6 minutes to copy in Turbo 
mode. 
 
 
When complete, check that the file now appears in the right window with the same size indicated as the 
original. If the file size is different, or sometimes 0kB, try copying it again. 
 
2. Convert the Topfield .rec file to an MPEG file. 
 
Download MPEG Streamclip. 
Go to www.squared5.com and download  MPEG Streamclip for Windows 1.2 
 
MPEG Streamclip is downloaded as a .zip file. You will also need to download Quicktime as well in order for 
Streamclip to work. You can either buy a version from Apple or download Quicktime Alternative 1.81 which 
is free. The latest versions of Quicktime Alternative will not work with Streamclip. Use version 1.81 which 
can be downloaded from www.filehippo.com/download_quicktime_alternative/?2615 
 
When you have downloaded it, find the file Quicktime Alternative 1.81.exe in your computer. Double click on 
it. This will run the installation programme. When you install Quicktime Alternative, you will also be offered 
Media Player Classic which is a another useful player for checking files. If you leave the Media Player box 
ticked and it will be installed as well.   
 
Find the downloaded MPEG Streamclip Zip folder. 
Right click on the folder and select "Extract all". An unzipped folder will be created. Open this folder, in 
which will be found the program, together with the instruction manual and notes. 
 
Windows 7 users will need to use the compatibility mode. Right click on the file MPEG_Streamclip.exe, and 
select Troubleshoot Compatibility. 
 



 

 

MPEG Streamclip does not come with an installation program, so it is useful to create a shortcut. 
Right click on the file MPEG_Streamclip.exe, select Create Shortcut, and drag the created shortcut on to 
the desktop area. 
 
It may be helpful to copy the instruction manual to wherever you keep similar documents in your computer.  
 
Open MPEG Streamclip. 
 
First set the preferences by selecting Window > Preferences.  
Tick "Fix Streams with Data Breaks" and "Convert only one audio track". Leave the other options unticked. 
 
Select File > Open files. 
Select the required .rec file and click "Open". 
The first picture of the file should appear. 
Play the file by clicking the |> button. 
Check that the vision and correct sound track plays. 
If you cannot hear the programme sound, select the correct audio track using the Audio PID dropdown box. 
How smoothly the vision and sound play depends on the specification of your computer. 
Do not be unduly concerned if the replay is jerky. When the file is converted, the computer will take as long 
as is necessary to do the job correctly. 
 
(If you are going to use a DVD Authoring program which has editing functions in the next stage, you can go 
straight to the file conversion step, without editing the file at this point.)   
 
Editing the file is achieved by marking a section of the file with In and Out times.  
Although it is possible to mark the In and Out times on any frame, if they are not key frames, when the file 
is cut, MPEG Streamclip will move the In time back to the previous key frame and the Out time forwards to 
the next key frame. 
It is, therefore, best to mark your In and Out times on key frames, so you can see what you will get. 
 
Below is the bottom part of the MPEG Streamclip screen.  

 

 
 
If the timeline and slider is missing on Windows 7 computers, the compatibility mode needs to be selected. 
 
First, find the start of the programme. The slider on the timeline can be used to move through the file. 
Clicking on the arrow buttons will increase or decrease the replay speed. 
The time displayed above the arrows is the frame currently being shown.  
 
Using the mouse to click on these buttons to find an exact point is not easy. It can get confusing if the 
computer responds slowly. The keyboard shortcuts shown on the next page are a useful alternative. 
 
 



 

 

 
 
Space Bar  =  Play/Stop 
Alt key + Page Up = Back 1 minute 
Alt key + Page Down = Forward 1 Minute 
Page Up = Back 10 secs 
Page Down = Forward 10 secs 
Up Arrow = Back 1 Key Frame 
Down Arrow = Forward 1 Key Frame 
Right Arrow = Back 1 Frame 
Left Arrow = Forward 1 Frame 
  
The aim is to find the first key frame of the programme. If the programme starts with a fade up, select the 
first black key frame after any unwanted material has finished. 
Use the up and down keys to step through the key frames. 
With the correct first frame displayed, press the I key to mark the In time. 
 
Next find the end of the programme. The aim is to find the last key frame of the programme before any 
unwanted material appears. 
 
Press the O key to mark the Out time. 
 
If the programme does not have any commercial breaks that you wish to remove, you can now convert the 
file, as described on the next page. Only the material between the marked In and Out times will be copied. 
 
 
 
 
 
 
If you are removing commercial breaks, 
Select Edit > Trim.  
 
This will delete the material before the In 
point and after the Out Point. 

 
 

 
 
 
 
 
Next find the first commercial break.  
 
If you are not sure where it is, go to the start of the programme. Fast forward or move the slider bar.  
Alternatively, if you hold down the Alt key, and repeatedly press Page Down, this will jump forward in one 
minute steps until you see a commercial.  
 
Use the Up and Down keys to find the last key frame of the programme before any End of Part caption or 
sponsor's logo appears.  
 
Press I to mark the In time. 



 

 

Next find the first key frame of the next part of the programme after any Beginning of Part caption 
disappears. 
 
Press O to mark the Out time. 
 
 
 
 
 
 
 
 
 
Select Edit > Cut to remove this 
marked section.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
When removing a commercial break delete any black frames after or before the programme material.  
However, if there is a fade down and up at the break, mark the last black key frame after the fade down and 
the first black key frame before the fade up. This will retain the fade down and up in the edited file. 
 
After you have made the cut, you can view it. Press the Page Up key to go back 10 seconds and then the 
Space Bar to play. 
If you are unhappy with the edit you can select Edit > Undo to undo it. You can then adjust the in or out  
times and try again. You can only undo the last cut you made. You can undo the trimming of the start and 
end at any time by selecting Edit > Revert Trimming. The Revert All Changes option will delete all your 
trimming and cuts. 
 
Repeat the process for the other commercial breaks, taking care not to miss any. 
 
 
 
 
 
 
 
 
 
 



 

 

File Conversion 
 
 
 
 
 
Select File > Convert to MPEG.  
 
Choose the correct folder for 
the file and press OK. 
 

 
 
 
 
 
 
 
 

 
A progress bar will be displayed as the 
file is converted. If any data break 
warnings appear, MPEG Streamclip 
should correct them, although a large 
number of breaks indicate that the 
converted file should be checked for 
errors. 
 

 
At this point it is worth checking the .mpg file. Minimise MPEG Streamclip. Don’t close it until you have 
checked the file. 
 
Open the .mpg file and check that it plays OK. Check that the vision and sound are both present and in 
sync at several points in the programme. If the .mpg file is OK, it can be used for DVD Authoring. 
 
If are problems with the audio, try fixing the file with PVAStrumento as described below.  
 
In the DVD Authoring stage you have the option of using a still frame from the programme as a background 
for the DVD menu. If you wish to do this, use MPEG Streamclip to find a suitable frame, select File > Export 
Frame. Select OK to save the frame as a .jpg file. 
 
PVAStrumento  
As mentioned earlier in this guide, PVAStrumento is useful for fixing audio problems. If your mpeg file 
seems OK you can miss out this section for now and move on to the DVD Authoring section. Come back to 
this section if you get a problem later. 
 
Download  PVAStumento. 
Go to www.offeryn.de/pvas_2_1.htm 
Download the zip file. 
Find the downloaded PVAStumento Zip folder. Right click on the folder and select extract all. 
An unzipped folder will be created. 
Find the folder pvas21022/gui and then the file PVAStrumento.exe. 



 

 

PVAStrumento does not come with an installation program, so it is useful to create a shortcut. 
Right click on the file PVAStrumento.exe, select Create Shortcut, and drag the created shortcut on to the 
desktop area 
 
Open PVAStumento 
 
Open the .mpg file by selecting the box 
marked ... next to the input stream box. 
 
Select Make PS. 
 
Choose a suitable folder and name for 
the file in the MPEG 2 File box. 
 
 
 
 
 
Click Start. Wait while the file is 
processed. 
 
 
At this point it is worth checking the 
mpeg file that you have made, 
particularly if the PVAStumento log 
screen above has shown errors while 
processing the file. 
 
 
 
 
If a Topfield file has errors in it, these were probably caused by reception problems when it was recorded 
and, unfortunately, there is no one method that fixes all types of faults. All you can do is to try different 
options and see which one works best. Another option is to try using demultipxed mpeg files (.mpv and 
.mpa) which can be created in both MPEG Streamclip and PVAStumento by selecting Demux instead. 
  
3.  DVD Authoring 
 
The process of creating the files for burning on to a DVD, together with an appropriate menu is known as 
DVD Authoring. 
 
In DVD terminology, each individual programme, episode or other item of programme material is known as 
a "Title". The DVD can be authored to play the titles in a particular order or as selected by the viewer 
through a menu. 
 
Each Title can be divided into a number of "Chapters". A chapter menu can be created to enable the viewer 
to choose to start viewing at the start of a particular chapter. Chapters are always replayed in sequence. 
Even if you do not wish to select individual chapter points yourself, it is useful to let the DVD authoring 
program automatically select chapter points at 10 or 15 minute intervals. This lets the viewer jump forward 
using the skip control on their remote. 
  
To download DVD Styler go to www.dvdstyler.org 



 

 

Select Downloads and choose the latest version (1.8.3 at the time of writing this guide) 
Select DVDStyler-1.8.3-win32u.exe which is the version for Windows. 
 
For a copy of the manual, return to the DVD Styler home page, select Docs and then the latest .pdf file 
labelled "Operation Manual English".  
 
After downloading, install the program by double clicking on DVDStyler-1.8.3-win32u.exe which will run the 
installation program. 
 
In order to generate some income for DVD Styler development, a setup window may appear which asks 
you if you want to change your search engine and home page. Assuming you don’t want this, select custom 
installation and install DVDStyler only. 
 
Open DVD Styler 
 
A welcome screen appears. Select “Create a new project” 
Select the options PAL, 16:9 Aspect Ratio, and MP2 Audio, since these are the properties of Topfield files.  
Click OK. 
 
Some menu templates will appear. Select “No Template” since this guide will be showing you how to create 
a new menu. As an example, this guide will demonstrate how to make a DVD containing two episodes of a 
series with a simple menu. 
 
The Menu Editing Window will appear in 
the main part of the screen. 
On the left is the Program Window for 
selecting files and menu features. 
At the bottom is the Project Timeline with a 
blank menu at the start. 
 
Select  Configuration > Settings and 
change the default settings to PAL 
720x576, 16:9 Aspect Ratio, and MP2 
Audio. These default settings will apply next 
time you open DVD Styler.   
 
With the "Backgrounds" tab on the left of 
the screen selected, select a suitable menu 
background from those offered, by double 
clicking on it. 
 
In this example, a light blue plain  
background has been selected.  
 
Select the "File Browser" tab. 
 
Find the folder containing your MPEG files. 
 
(To use an MPEG file that has the extension .m2p, the extension must be changed to .mpg in Windows 
Explorer or DVD Styler will not recognise it.)   
 
Find the .mpg or .mpv file for the title that you want to be played first on your DVD. 



 

 

Select the file with your mouse and, 
holding down the left button, drag the 
icon down into the timeline, to the right 
of the menu icon. Release the mouse 
button. 
If the file is an .mpv file (vision only), 
find the corresponding .mpa (sound) file 
in the directory window and drag it over 
the .mpv file in the timeline. 
If you are putting more than one title on 
your DVD, Find the next title and drag it 
into the timeline. Add the sound file if 
required. 
If you are going to copy the files and not 
re-encode them, the total size of the title 
files should not exceed 4380 Mb or the 
titles will not fit on a 4.7Gb disc. If you 
place your mouse over an icon in the 
File Browser, the file name and size will 
be shown at the bottom of the screen. If you place your mouse over an icon in the timeline the duration will 
be shown. 
 
The total duration of the titles and disc capacity in minutes is shown at the bottom of the screen. The video 
bitrate shown in the bottom right corner only applies if you are re-encoding the files. It should always read 
8MB/s if all the files are being copied.  
 
Re-encoding may be a useful option if you wish to 
squeeze more titles on a single DVD, although this will 
reduce the picture quality and increase the time taken 
to author the DVD. As you add more titles the video 
bitrate shown will be reduced in order to increase the 
disc capacity.  
 
You should now set the properties of each title. Go to 
the timeline, right click on the icon for the title and 
select Properties. 
 
If the .mpg file does not have 740x576 video with mp2 
audio the properties will have been set to re-encode 
the files to these formats. 
 
Change these to Copy for both vision and sound if you 
do not wish to re-encode the files. 
 
The chapter times will be set at 10 minute intervals for 
the duration of the title. Leave these unchanged 
unless you have more accurate times to use.   
 
The post command box sets what will happen when 
the title finishes playing. The default setting is to return 
to the menu.  
 



 

 

If you would like the DVD to go straight to playing Title 2 after Title 1 finishes, change the post command of 
the Title 1 properties to "Jump title 2". 
 
Menu Design 
 
To design a menu, you first need to select 
some text and buttons. A button is some text 
or a symbol that is selected by the viewer to 
perform a particular action. 
 
Select the "Buttons" tab on the left of the 
screen.  Select a button with your mouse. 
The one labelled "Button" will do for this 
example. 
 
Drag the button into the menu window and 
place it in a suitable position. Release the 
mouse button. The button text will change to 
"Button 1" 
 
If there is only one title, one button is 
enough.  
 
In the example shown, there are two titles, so select the same button again in the button menu and drag it 
to another position in the menu window. 
 
The button text will change to "Button 2" Select more buttons for any other titles. 
 
To change the button text, right 
click on the button and select 
Properties. 
 
Type the required text in the label 
box. In this example, "Play 
Episode 1".  Since the type is 
rather small, select the font 
button and choose a larger size. 
 
The action performed by the 
button is selected in the “Action”- 
"Jump to" box. 
For the first title leave as the 
default, "Play Title 1". 
 
You can also change the colour 
of the text. 
 
"Normal" is the colour of all the 
unselected buttons, if there is 
more than one. 
 
 



 

 

"Highlighted" is the colour of the button selected using the arrow buttons on the DVD remote control. 
 
"Selected"  is the colour that the highlighted button will change to when "Enter" is selected on the remote. 
If you change the colours, ensure that all 3 colours will be visible on the background.   
Press OK. 
 
For the second button in this example, change the label text to "Play Episode 2". The Jump to box must be 
changed to "Title 2" so that the DVD plays the correct episode when the button is selected by the viewer. 
 
Additional text can be added to the screen by right-clicking anywhere on the screen. 
 
Select Add > Text 
 
Type the required text in the text 
box. In this example type the Name 
of the Series. To change the font, 
right click on the button and select 
Properties. 
 
Select the font and choose OK 
 
If there are only 2 buttons on the 
screen, it is helpful to the viewer if 
there is some additional text of the 
same colour as the normal button 
colour, otherwise it is not obvious 
which button is highlighted. 

 
Having set the text of the buttons, 
their positions on the screen can be 
moved by holding down the left 
mouse key. Change the text size, if needed. 
 
 
Other Menu Options 
 
DVD Styler offers a wide variety of 
menu design options, see the DVD 
Styler instruction manual for more 
details. 
 
One option, shown here, is to use a 
still frame from the programme as 
the menu background. This needs to 
be chosen and saved as a .jpg file in 
the previous stage using MPEG 
Streamclip. 
 
Double click on the .jpg file in DVD 
Styler to select it. The position and 
colour of the buttons will need to be 
changed to suit the picture. 



 

 

 
Saving Your Design 
 
You can save the file and menu settings by selecting the icon with the green arrow at the top of the screen. 
 
 

4. DVD Burning 
 

Select the red Burn icon. 
 

DVD Styler will create the required files and then 
burn the DVD. 
 
It is also possible to just create an .iso image file 
which is an exact copy of the data that would be 
recorded on the DVD, and then burn the disc 
later.  
 
Select either "Create iso image" or "Burn DVD" 
 
Create a folder in the temporary directory box for 
the temporary files. 
   
If you are creating an iso file, choose a suitable 
folder and name for it in the “Save to” box.  
 
If you are burning the DVD, insert a blank disc 
and check the correct drive is selected. 
 
If you are using a new DVD-RW disc or are re-using one that has not been erased, tick the format DVD-RW 
box.  
 
Select Start. 
 
Details are displayed as the process continues. If you are re-encoding the files this will take a long time, 
possibly up to twice the duration of the programme material. The “fps=” figure in the log file indicates the 
speed of encoding. If you are just copying the files, this should only take a few minutes. Some stages of the 
process give more regular updates than others, so there may be several minutes while nothing appears to 
be happening. Eventually, an estimated finish time will be displayed.  
 
Note any warning messages. Serious ones are coloured red. 
 
Watch out for messages like: 
WARN: Discontinuity of in audio channel 
WARN: audio sector out of range 
This means that you have some out of sync or missing audio at some point on your DVD. 
 
One problem with DVD Styler is that some computers will occasionally not delete some temporary files, 
because they are being accessed by another the program. This can occur if a file indexing program, such 
as Google Desktop, is operating in the background. The best solution is to uninstall Google Desktop. This 
problem will also arise if you cancel the burning operation before it has finished. If you get a "can't delete 
file" error message, choose a different folder name in the temporary directory box and Start again. 



 

 

These temporary files can be deleted later when the computer is next restarted. 
 
Hopefully you will get a green message saying the DVD has been burnt OK. 
 
If you have chosen to make an .iso file, you can open this file using VLC Media Player.  VLC Media Player 
will enable you to check the vision, sound and menu buttons before burning the disc. Note that VLC Media 
Player will not always display text buttons correctly, however, these should be OK on the disc. The main 
aim is to check the sound and vision. To burn the disc you will need to use a separate program. If a disc 
burning program was not provided with your computer, there are a number of disc burning programs 
available to download, such as ImgBurn. (www.imgburn.com) 
 
Check the disc in a DVD player. Check that the all menu buttons perform to intended function. Check that 
the vision and sound play correctly and are in sync with each other at several points in the programme. Go 
to the end of the programme and check that the player plays either the next title or returns to the menu as 
intended. If there are any problems with the vision or sound, re-check the same points by playing the MPEG 
files that were used to create the DVD, to find out where the problem may have occurred. You may need to 
try different options for creating the MPEG files as described in the previous section.  
 
When you have successfully created a few DVDs, don't forget to delete all the intermediate files. Otherwise 
your computer's hard disc will soon get full up. 
 
Good Luck 
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